CORRECTION TRANSMATH TS PDF Free Download

CORRECTION TRANSMATH TS PDF Free Download

NameCORRECTION TRANSMATH TS
FormatPDF
Size14 mb
CORRECTION TRANSMATH TS PDF Free Download

1Enseignement spcifique Pratiquer l’algorithmique

Nathan 2012 Transm

ath Term

. S

Pratiquer lalgorithmique

THME 1 Quest-ce quun algorithme ?Activit

2 Trac dau moins deux hauteurs issues des sommets du triangle. Trac du point H, intersection des hauteurs traces.3 Traitement : le trac des hauteurs.

Exercices

1 1. Les points O et A.2. Un carr de centre O et dont un sommet est A.

2 lments donns : lexpression de f (x) et la valeur a. Question pose : Donnez lquation de la tangente la courbe reprsentant f au point dabscisse a.3 Entres : les coefficients A, B et C du trinme.

Traitements : le calcul du discriminant DELTA. Sorties : les valeurs a et b.4 1. On peut dduire le sens de variation de la fonction

f sur lintervalle I.

  1. b)

f est positive pour x 1 et pour x 2. Donc la fonction f est strictement croissante sur ] ; 1] et [2 ; + [ et stric-tement dcroissante sur [1 ; 2].

5 Les entres de ces deux algorithmes ne sont pas identiques. On ne peut donc pas dire que ces algorithmes sont quivalents.

6 Crez dans lordre : le triangle ABC, deux bissectrices intrieures ce triangle, le point dintersection D des deux bissectrices, la perpendiculaire lun des cts passant par le point D, le point dintersection E entre cette perpendiculaire et le ct utilis, le cercle de centre D passant par E. Utilisez la commande Crer un nouvel outil . Choisissez le cercle inscrit dans longlet objets finaux , les points A, B et C dans longlet objets initiaux .

2 Enseignement spcifique Pratiquer l’algorithmique

Nathan 2012 Transm

ath Term

. S

b) Oui. Voir la question 2.2. Avec AlgoBox :

11 1. p, n, t, PHT et PTTC.2. PHT PREND_LA_VALEUR np PTTC PREND_LA_VALEUR PHT(1+t/100)3. a) p, n, t.b) p PREND_LA_VALEUR np p PREND_LA_VALEUR p(1+t/100)c) Lconomie du nombre de variables dgrade la lisibilit de lalgorithme.

Activit1 On obtient f (4).

2 5 3 EXE 2 EXE

Exercices

7 5 5 + 4 4 EXE EXE

8 a) 4 A EXE A 2

B

EXE

A

B

  • 5 EXE

b) 4 + 2 A EXE 2 5 A EXE

9 A

2 ; B

3 ; C

1 .

10 1. a) On peut envisager jusqu cinq variables : le premier nombre A, le carr B de ce premier nombre, le second nombre C, le carr D de ce second nombre, la somme E de B et D.

THME 3 Linstruction conditionnelleActivit

Exercices

12 T.I.

Casio

13 1. Il suffit dajouter une variable p et la ligne de traitement p prend la valeur b-m*a .2. Avec AlgoBox :

1 VARIABLES2 a EST_DU_TYPE NOMBRE3 b EST_DU_TYPE NOMBRE4 c EST_DU_TYPE NOMBRE5 d EST_DU_TYPE NOMBRE6 m EST_DU_TYPE NOMBRE7 p EST_DU_TYPE NOMBRE8 DEBUT_ALGORITHME9 AFFICHER Saisissez les coordonnes

du point A.10 LIRE a11 LIRE b12 AFFICHER Saisissez les coordonnes

du point B.13 LIRE c14 LIRE d15 // On calcule les paramtres de la

droite16 m PREND_LA_VALEUR (d-b)/(c-a)17 AFFICHER Le coefficient directeur

de (AB) est 18 AFFICHER m19 p PREND_LA_VALEUR b-m*a20 AFFICHER Lordonne lorigine

de (AB) est 21 AFFICHER p22 FIN_ALGORITHME

THME 2 Variables et affectation

3Enseignement spcifique Pratiquer l’algorithmique

Nathan 2012 Transm

ath Term

. S

  1. Avec AlgoBox :

1 VARIABLES2 a EST_DU_TYPE NOMBRE3 b EST_DU_TYPE NOMBRE4 c EST_DU_TYPE NOMBRE5 d EST_DU_TYPE NOMBRE6 m EST_DU_TYPE NOMBRE7 p EST_DU_TYPE NOMBRE8 DEBUT_ALGORITHME9 AFFICHER Saisissez les coordonnes

du point A.10 LIRE a11 LIRE b12 AFFICHER Saisissez les coordonnes

du point B.13 LIRE c14 LIRE d15 SI (a==c) ALORS16 DEBUT_SI17 AFFICHER (AB) est parallle (Oy)

et a pour quation x = 18 AFFICHER a19 FIN_SI20 SINON21 DEBUT_SINON22 m PREND_LA_VALEUR (d-b)/(c-a)23 AFFICHER Le coefficient directeur

de (AB) est 24 AFFICHER m25 p PREND_LA_VALEUR b-m*a26 AFFICHER Lordonne lorigine

de (AB) est 27 AFFICHER p28 FIN_SINON29 FIN_ALGORITHME

14 a) Cet algorithme teste la colinarit ou lortho-gonalit de deux vecteurs dfinis par leurs coordonnes.Ligne 15 : colinaires. Ligne 19 : orthogonaux. b) et c) Le programme AlgoBox final peut tre :

1 VARIABLES2 a EST_DU_TYPE NOMBRE3 b EST_DU_TYPE NOMBRE4 c EST_DU_TYPE NOMBRE5 d EST_DU_TYPE NOMBRE6 k EST_DU_TYPE NOMBRE7 message EST_DU_TYPE CHAINE8 DEBUT_ALGORITHME9 AFFICHER Entrez les coordonnes du

vecteur u.10 LIRE a11 LIRE b12 AFFICHER Entrez les coordonnes du

vecteur v.13 LIRE c14 LIRE d15 SI (a==0 et b==0) ALORS16 DEBUT_SI17 AFFICHER u est nul.18 FIN_SI19 SI (c==0 et d==0) ALORS20 DEBUT_SI21 AFFICHER v est nul.

22 message PREND_LA_VALEUR v= 0 u.23 FIN_SI24 SINON25 DEBUT_SINON26 SI (c==0) ALORS27 DEBUT_SI28 k PREND_LA_VALEUR b/d29 message PREND_LA_VALEUR

u = +k+ v.30 FIN_SI31 SINON32 DEBUT_SINON33 k PREND_LA_VALEUR a/c34 message PREND_LA_VALEUR

u = +k+ v.35 FIN_SINON36 FIN_SINON37 SI (ad-bc==0) ALORS38 DEBUT_SI39 AFFICHER u et v sont colinaires.40 AFFICHER message41 FIN_SI42 SI (ac+bd==0) ALORS43 DEBUT_SI44 AFFICHER u et v sont orthogonaux.45 FIN_SI46 FIN_ALGORITHME

15 T.I.

Casio

16 1.

Entres SortiesA B C A B H4 8 7 4 7 88 7 4 4 7 88 4 7 7 4 84 7 8 4 7 8

4 Enseignement spcifique Pratiquer l’algorithmique

Nathan 2012 Transm

ath Term

. S

THME 4 La boucle conditionnelle

Activit4 Le dixime carr a un ct infrieur 0,5.

Exercices

17 1. et 2.

T.I.

Casio

Remarque. Dans le langage de programmation CASIO, les instructions dune boucle Do-LpWhile sont excutes une premire fois, puis tant que la condition est vrifie.

18 1. Au dbut du jeu, le livre et la tortue sont derrire la ligne de dpart. Un d est lanc. Si le rsultat de ce

lancer est 6, alors le livre arrive directement sur la case Arrive et remporte la manche. Sinon, la tortue avance dun nombre de cases gal au rsultat du lancer. Si la tortue arrive sur la case Arrive , alors elle remporte la manche. On relance le d jusqu ce que lun des protagonistes remporte la manche.2. Avec AlgoBox :

1 VARIABLES2 T EST_DU_TYPE NOMBRE3 L EST_DU_TYPE NOMBRE4 D EST_DU_TYPE NOMBRE5 GL EST_DU_TYPE NOMBRE6 GT EST_DU_TYPE NOMBRE7 i EST_DU_TYPE NOMBRE8 DEBUT_ALGORITHME9 i PREND_LA_VALEUR 010 GT PREND_LA_VALEUR 011 GL PREND_LA_VALEUR 012 TANT_QUE (ic) ALORS22 DEBUT_SI23 h PREND_LA_VALEUR a24 a PREND_LA_VALEUR c25 FIN_SI26 FIN_SINON27 SI (hh==aa+b*b) ALORS28 DEBUT_SI29 AFFICHER Le triangle est rectangle.30 FIN_SI31 SINON32 DEBUT_SINON33 AFFICHER Le triangle nest pas

rectangle.34 FIN_SINON35 FIN_ALGORITHME

5Enseignement spcifique Pratiquer l’algorithmique

Nathan 2012 Transm

ath Term

. S

19 1. Avec AlgoBox :

1 VARIABLES2 u EST_DU_TYPE NOMBRE3 v EST_DU_TYPE NOMBRE4 a EST_DU_TYPE NOMBRE5 b EST_DU_TYPE NOMBRE6 p EST_DU_TYPE NOMBRE7 DEBUT_ALGORITHME8 u PREND_LA_VALEUR 29 v PREND_LA_VALEUR 110 LIRE p11 TANT_QUE (u-v>p) FAIRE12 DEBUT_TANT_QUE13 a PREND_LA_VALEUR (u+v)/214 b PREND_LA_VALEUR 4/(u+v)15 u PREND_LA_VALEUR a16 v PREND_LA_VALEUR b17 FIN_TANT_QUE18 AFFICHER v19 AFFICHER u20 FIN_ALGORITHME

  1. On modifie les lignes suivantes :

8 u PREND_LA_VALEUR 514 b PREND_LA_VALEUR 10/(u+v)

20 1. Selon les habitudes de programmation, les rpon ses peuvent tre varies. Voici un algorithme utilisant les oprateurs de base :

Variablesa, b et c sont de type numriqueEntreLire a et bTant que a>0 R prend la valeur a a prend la valeur a-bFin de boucleSortieAfficher R

  1. La structure jusqu nexiste pas pour tous les langages de programmation. On utilise alors une structure tant que en sassurant que les instructions de la boucle seront excu-tes au moins une fois. Exemple avec AlgoBox :
  2. PGCD(660 ; 1 050) = 30 et PGCD(4 410 ; 2 100) = 210.

31 GT PREND_LA_VALEUR GT+132 FIN_SI33 D PREND_LA_VALEUR ALGOBOX_ALEA_

ENT(1,6)34 FIN_TANT_QUE35 FIN_TANT_QUE36 AFFICHER Nombre de parties gagnes

par le livre : 37 AFFICHER GL38 AFFICHER Nombre de parties gagnes

par la tortue : 39 AFFICHER GT40 FIN_ALGORITHME

3.

1 VARIABLES2 T EST_DU_TYPE NOMBRE3 L EST_DU_TYPE NOMBRE4 D EST_DU_TYPE NOMBRE5 GL EST_DU_TYPE NOMBRE6 GT EST_DU_TYPE NOMBRE7 gagnant EST_DU_TYPE CHAINE8 DEBUT_ALGORITHME9 //La tortue et le livre sont derrire

la ligne de dpart.10 T PREND_LA_VALEUR 011 D PREND_LA_VALEUR 012 TANT_QUE (T=7) ALORS29 DEBUT_SI30 //Si la tortue franchit la ligne

darrive alors elle gagne la partie.

31 gagnant PREND_LA_VALEUR la tortue.32 FIN_SI33 FIN_TANT_QUE34 AFFICHER Le gagnant est : 35 AFFICHER gagnant36 FIN_ALGORITHME

  1. La tortue semble avantage. En modifiant le programme, on peut conjecturer que pour 10 ou 11 cases, le jeu est plus quitable.

6 Enseignement spcifique Pratiquer l’algorithmique

Nathan 2012 Transm

ath Term

. S

THME 5 La boucle incrmentaleActivit

1 a) Ligne 6 : u prend la valeur 5 Ligne 10 : Tant que i < p Ligne 11 : u prend la valeu

Recommended

CHAPITRE 4 Matrices – .CHAPITRE Spécialité Chapitre 4 Matrices 1 © Nathan 2012 – Transmath Term
SPLIT-TYPE ROOM AIR CONDITIONER Installation Manual tS.pdf The air conditioning system comes with the
E tutorial – Online Correction – Challlan Correction
Correction – PNAS Correction BIOPHYSICS AND COMPUTATIONAL BIOLOGY Correction for “SNARE machinery
TRANSMATH 6e – أ‰ditions Nathan TRANSMATH 6. e – أ‰ditions Nathan . 14 . Animation Descriptif Page
CORRECTION Open Access Correction: Comparative analysis of 2017-08-26آ CORRECTION Open Access Correction:
ORGANISATION DE LA REPONSE AMBULANCIERE solidarites-sante.gouv.fr/IMG/pdf/Referentiel_SAMU-TS.pdf ·
The fastest way to scan – ZF- correction models (geoid correction ï¬ les) • Correction: … Software Module Basic Calibration Correction Calibration Correction Software Module
Author Correction: Identification of a Novel Feruloyl … AUTHOR CORRECTION Author Correction: Identification
Correction and Retractions – PNAS Correction and Retractions CORRECTION BIOCHEMISTRY Correction for
Manual de Normas Gráficas de Transantiago – dtpm.cl de normas graficas TS.pdf · 2.3 Paradero básico
TRABAJO – up.ac.pa TS.pdf · Estadística Descriptiva … 2 7 AULA: 405 Trabajo Social Año I Turno:
환경피로해석및 주요기기피로관리현황 .Correction Factor, F … Reference Correction
Correction – pnas.· Correction GENETICS Correction … as a reviewer. ” … fragmented system to
Correction Correction APPLIED BIOLOGICAL SCIENCES, ENGINEERING Correction for “Dendrimer-RNA nanoparticles
NAFKAH HAK ANAK OLEH PNS – Darulilmy TS.pdf · iii NAFKAH HAK ANAKOLEH PNS (Analisis Putusan Mahkamah
Les cahiers Transmath Bon de Transmath Collأ¨ 2014. 4. 17.آ Les cahiers Transmath L’idأ©al pour le
Scorpio – TS.pdf · • Diseño patentado de un solo eje • Mejora de la estabilidad … (mm) (mm)
CORRECTION Open Access Correction: Production of … … CORRECTION Open Access Correction: Production
Bloque 4_Primeros Pasos en TS.pdf
View More >
About usContact usTermDMCA
English
Français
Español
Deutsch

Updated: October 10, 2021 — 10:47 pm

Leave a Reply

Your email address will not be published. Required fields are marked *